<!DOCTYPE html>
<html lang="en" xmlns="https://www.w3.org/1999/xhtml" xmlns:og="//opengraphprotocol.org/schema/" xmlns:fb="https://www.facebook.com/2008/fbml" class="prod body">
    <head>
        <!-- META TAGS -->
        <meta charset="UTF-8"/>
                                                                                                                                                                
                            <meta name="viewport" content="width=device-width, initial-scale=1">
        
            <meta name="title" content="HE-MAN Documentary POWER OF GRAYSKULL Coming to Home Video"><meta name="description" content="Learn the history of HE-MAN with THE POWER OF GRAYSKULL on DVD."><title>HE-MAN Documentary POWER OF GRAYSKULL Coming to Home Video</title><meta http-equiv="X-UA-Compatible" content="IE=9; IE=8; IE=7; IE=EDGE"><script type="text/javascript">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</script><meta name="google-site-verification" content="">    
            <meta name="robots" content=" index, follow ">
    
            <link rel="canonical" href="https://www.newsarama.com/46352-he-man-documentary-power-of-grayskull-coming-to-home-video.html">
    
    
                    <meta property="fb:app_id" content="552196711477189" />
<meta property="fb:pages" content="" />
<meta property="og:title" content="HE-MAN Documentary POWER OF GRAYSKULL Coming to Home Video" />
<meta property="og:url" content="https://www.newsarama.com/46352-he-man-documentary-power-of-grayskull-coming-to-home-video.html" />
<meta property="og:image" content="https://img.purch.com/h/1000/aHR0cDovL3d3dy5uZXdzYXJhbWEuY29tL2ltYWdlcy9pLzAwMC8yNjIvMTMyL29yaWdpbmFsL1BPV0VST0ZHUkVZU0tVTEwtS0VZQVJULmpwZw==" />
<meta property="og:type" content="article" />
<meta property="og:site_name" content="Newsarama" />
<meta property="og:description" content="Learn the history of HE-MAN with THE POWER OF GRAYSKULL on DVD." />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@Newsarama" />
<meta name="twitter:site:id" content="15433228" />
<meta name="twitter:creator" content="@Newsarama" />
<meta name="twitter:title" content="HE-MAN Documentary POWER OF GRAYSKULL Coming to Home Video" />
<meta name="twitter:description" content="Learn the history of HE-MAN with THE POWER OF GRAYSKULL on DVD." />
<meta name="twitter:image" content="https://img.purch.com/h/600/aHR0cDovL3d3dy5uZXdzYXJhbWEuY29tL2ltYWdlcy9pLzAwMC8yNjIvMTMyL29yaWdpbmFsL1BPV0VST0ZHUkVZU0tVTEwtS0VZQVJULmpwZw==" />
        <meta property="fb:title" content="" />
        <meta property="fb:description" content="" />
        <meta property="og:image:height" content="600"/>
        <meta property="og:image:width" content="315"/>
            <link rel="icon" type="image/png" href="/medias/favicon/favicons32x32.png?v=kPPAMMXoY2" sizes="32x32">
<link rel="icon" type="image/png" href="/medias/favicon/favicons64x64.png?v=kPPAMMXoY2" sizes="64x64">
<link rel="icon" type="image/png" href="/medias/favicon/logo-transparent.png?v=kPPAMMXoY2">
<link rel="icon" type="image/png" href="/medias/favicon/logo-transparent-white.png?v=kPPAMMXoY2">

<link rel="icon" type="image/png" href="/medias/favicon/favicons128x128.png?v=kPPAMMXoY2" sizes="128x128">
<link rel="manifest" href="/medias/favicon/manifest.json?v=kPPAMMXoY2">

<meta name="msapplication-TileColor" content="#023953">
<meta name="theme-color" content="#023953">
            <meta name="news_keywords" content="he-man,masters of the universe,power of grayskull,mattel "/>
        <link rel="amphtml" href="https://amp.newsarama.com/46352-he-man-documentary-power-of-grayskull-coming-to-home-video.html">                             <!--[if lt IE 9]>
        <script src="//html5shim.googlecode.com/svn/trunk/html5.js"></script>
        <![endif]-->

                
                <link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Ubuntu:400,700" /><link rel="stylesheet" href="/css/compiled/grunt/newsarama-site.edito.article.css?3.10.0-191"/>
        <!--[if lte IE 8]>
                <![endif]-->

                
        <script language="JavaScript" type="text/javascript">
        var Purch = Purch || {};
        Purch.Omniture = Purch.Omniture || {};
        Purch.Omniture.params = Purch.Omniture.params || {};
    </script><script class="omnitureParams" language="JavaScript" type="text/javascript">
                Purch.Omniture.params.prop33 = '';
                Purch.Omniture.params.eVar36 = '';
                Purch.Omniture.params.eVar37 = '';
                Purch.Omniture.params.eVar49 = '3.10.0\x2D191';
                Purch.Omniture.params.channel = 'film\x2Dtv';
                                Purch.Omniture.params.eVar5 = 'he\x2Dman\x20documentary\x20power\x20of\x20grayskull\x20coming\x20to\x20home\x20video';
                Purch.Omniture.params.eVar16 = '';
                Purch.Omniture.params.eVar17 = '';
                Purch.Omniture.params.eVar18 = '';
                Purch.Omniture.params.contentID = 'na';
                Purch.Omniture.params.pageName = '';
                Purch.Omniture.params.prop1 = '';
                Purch.Omniture.params.prop15 = '';
                Purch.Omniture.params.prop16 = '';
                Purch.Omniture.params.prop17 = '';
                Purch.Omniture.params.prop18 = '';
                Purch.Omniture.params.prop2 = 'na';
                Purch.Omniture.params.prop3 = '';
                Purch.Omniture.params.prop4 = 'article';
                Purch.Omniture.params.prop5 = 'he\x2Dman\x20documentary\x20power\x20of\x20grayskull\x20coming\x20to\x20home\x20video';
                Purch.Omniture.params.prop6 = 'na\x2D46352';
            Purch.Omniture.params.eVar15 = (Purch && Purch.User && Purch.User.Status ? Purch.User.Status : '');
    Purch.Omniture.params.prop35 = (Purch && Purch.User && Purch.User.Id ? 'na-en'+Purch.User.Id : '');
    Purch.Omniture.params.pageURL = window.location.href;
    if (window.location.hash != "") {
        Purch.Omniture.params.campaign = window.location.hash.replace('#','');
    }
</script><script language="JavaScript" type="text/javascript">
        Purch.Omniture.s = Purch.Omniture.params;
    </script>
                <script type="text/javascript">
        var gtmDataLayer = gtmDataLayer || [];
        gtmDataLayer.push({'PurchObfCssMap': Purch.obfCssMap});
        gtmDataLayer.push({'PurchOmnitureParams': Purch.Omniture.params});
        //Cross compatibility with existing gtm datalayer variables
        gtmDataLayer.push({'OmnitureVars': Purch.Omniture.params});
    </script><!-- Google Tag Manager --><script id="gtmScript" data-id="GTM-5L6TX4">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start': new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
        })(window,document,'script','gtmDataLayer','GTM-5L6TX4');</script><!-- End Google Tag Manager --><script>
                if (typeof Object.assign !== 'function') document.write('<scr'+'ipt src="/js/vendor/object.assign.js"></sc'+'ript>');
            </script><script>
                !function(){if("function"==typeof window.CustomEvent)return!1;function t(t,e){e=e||{bubbles:!1,cancelable:!1,detail:void 0};var n=document.createEvent("CustomEvent");return n.initCustomEvent(t,e.bubbles,e.cancelable,e.detail),n}t.prototype=window.Event.prototype,window.CustomEvent=t}();
            </script><script type="text/javascript" src="/js/Purch/require.js"></script><script type="text/javascript">
                var Purch = Purch || {};
                Purch.initRequire = false;
                requirejs.config({
                    waitSeconds: 0,
                    baseUrl: '/js',
                    urlArgs: 'v=3.10.0-191',
                    paths: {
                        jquery: '/js/vendor/jquery/jquery.min',
                        hammerjs: '/js/vendor/hammerjs/hammer.min',
                        promise: 'https://cdnjs.cloudflare.com/ajax/libs/es6-promise/4.1.1/es6-promise.auto.min',
                        lock: 'https://cdn.auth0.com/js/lock/11.3.1/lock.min',
                        sortable: '/js/vendor/sortable.min'
                    }
                });
                if (typeof jQuery === 'function') {
                    define('jquery', function() { return jQuery; });
                    define('jQuery', [], function() { return jQuery; });
                }
                var domInteractive = function() {
                    Purch.initRequire = true;
                            
    require(['Purch/Utils/Tracking'], function(Tracking) {
        Tracking.initModule({
            targets: '.right-rail-section .subscribe .btn',
            onEvent: 'mousedown',
            gtmDataLayerName: 'gtmDataLayer',
            gtmPushData: {
            "event": "newsletter",
            "location": "right-rail"
            }
        });
    });

    require(['Purch/UI/Zoom'], function (Zoom) {
        Zoom.initModule({targets: '.magnify-wrapper img[big-src]', closeOnScroll: false});
    });
                };
                document.addEventListener('readystatechange', function() {
                    if (!Purch.initRequire && ['interactive', 'complete'].indexOf(document.readyState) >= 0) {
                        domInteractive();
                    }
                }, false);
            </script><script class="ramp-tagscripts" language="JavaScript" type="text/javascript">
                        var Purch = Purch || {};
                        Purch.Ramp = Purch.Ramp || {};
                        Purch.cs_extradata = Purch.cs_extradata || {};                                                Purch.cs_extradata.CATEGORY = 'film-tv';
                                                                        Purch.Ramp.account = 'YXJ0aWNsZS9maWxtLXR2';                        Purch.Ramp.target = [];
                        var tmntag = tmntag || {};
                        tmntag.cmd = tmntag.cmd || [];
                        (function() {
                            var tmnh = document.createElement('script');
                            tmnh.type = 'text/javascript';
                            tmnh.async = true;
                            tmnh.src = 'https://ads.servebom.com/tmnhead.js';
                            var s = document.getElementsByTagName('script')[0];
                            s.parentNode.insertBefore(tmnh, s);
                        })();

                        tmntag.cmd.push(function(){
                            if (document.location.hash.indexOf('#xtor=') != -1) {
                                Purch.Ramp.target.xtor = document.location.hash.substr((document.location.hash.indexOf('#xtor=') + 6), document.location.hash.length);
                            }
                            tmntag.target(Purch.Ramp.target);
                                                        try{tmntag.account(window.atob(Purch.Ramp.account));}catch(er){}
                                                        tmntag.placement('2808');
                            tmntag.start();
                        });
                    </script>                    
<style>  #header_leaderboard{min-height:0px} @media only screen and (min-width:748px) {#header_leaderboard{min-height:90px}}  #rightcol_top{min-height:0px} @media only screen and (min-width:748px) {#rightcol_top{min-height:250px}}</style>
<script>
var Purch = Purch || {};
Purch.JwDisableSticky = document.location.pathname === "/";
</script>
<link rel="manifest" href="/manifest.json" />
<script src="https://cdn.onesignal.com/sdks/OneSignalSDK.js" async ></script>
<script id="onesignal_tag" data-app-id-http="e1217ed1-b2ce-47f3-8de3-8d2feaf923bb" data-app-id-https="ca1fe6fd-b40e-4cbd-86a9-423170446162" src="https://assets.purch.com/creative-templates/2.0.3-752/js/membership/OneSignal/LoadOneSignal.js" async ></script>
<script type="text/javascript">
  
(function () {
	
function getOmnitureData() {
  return (Purch.Omniture.params) || {};
}
		
var DiscoveryConf = {
  'etype': 'click',
  
  'p': {
	 'tid%7C\\w+': function(conf) {
		 try{
			if(conf.el.getAttribute('data-omniture-tracking')){ 
				var omnitureTrackingVars = conf.el.getAttribute('data-omniture-tracking');
				var parsedVars = JSON.parse(omnitureTrackingVars);
				return 'tid%7C' + parsedVars["evars"]["transactionID"];
			  }
		 }catch(e){}
	}
  },
  'providers': ['out.tomsguide.fr', 'amazon.fr', 'amazon.co.uk',
	  'amazon.de', 'Mediaplex.com', 'amazon.com', 'Geni.us',
	  'linksynergy.com', 'lenovo.7eer.net',
	  'sharesale.com', 'evyy.net', 'dpbolvw.net',
	  'kqzyfj.com', 'anrdoezrs.net', 'tkqlhce.com', 'jdoqocy.com',
	  'parrot.com'
  ],
 'noDiscoverSelector': 'a[class*="hawk-"],a[data-clickstream-disable="true"]',
  'd': {
	  'esubtype': 'buybttn',
	  'buttonId': function(conf) {
		 try{
			if(conf.el.getAttribute('data-omniture-tracking')){
			  var omnitureTrackingVars = conf.el.getAttribute('data-omniture-tracking');
			  var parsedVars = JSON.parse(omnitureTrackingVars);
			  return parsedVars["evars"]["eVar18"];
			} else {
			  return null;
			}
		 }catch(e){}
	
	  },
	  'productId': function(conf) {
		try{
			if(conf.el.getAttribute('data-omniture-tracking')){
			  var omnitureTrackingVars = conf.el.getAttribute('data-omniture-tracking');
			  var parsedVars = JSON.parse(omnitureTrackingVars);
			  var productId = parsedVars["evars"]["eVar18"];
			  return productId && productId.substr(productId.indexOf('-') + 1);
			} else {
			  return null;
			}
		 }catch(e){}
	  },
	  'merchant': function(conf) {
		try{
			if(conf.el.getAttribute('data-omniture-tracking')){
			  var omnitureTrackingVars = conf.el.getAttribute('data-omniture-tracking');
			  var parsedVars = JSON.parse(omnitureTrackingVars);
			  return parsedVars["evars"]["eVar34"];
			} else {
			  return null;
			}
		}catch(e){}
		
	  },
	  'price': function(conf) {
		try{
			if(conf.el.getAttribute('data-omniture-tracking')){
			  var omnitureTrackingVars = conf.el.getAttribute('data-omniture-tracking');
			  var parsedVars = JSON.parse(omnitureTrackingVars);
			  return parsedVars["evars"]["eVar43"];
			} else {
			  return null;
			}
		}catch(e){}
	
	  },
	  'adPlacement': function(conf) {
		try{
			if(conf.el.getAttribute('data-omniture-tracking')){
			  var omnitureTrackingVars = conf.el.getAttribute('data-omniture-tracking');
			  var parsedVars = JSON.parse(omnitureTrackingVars);
			  return parsedVars["evars"]["eVar23"];
			} else {
			  return null;
			}			  
		}catch(e){}
		
	  },
	  'categories': function() {
		try{
			return getOmnitureData()['eVar2'];  
		}catch(e){}
	  },
	  'tags': function() {
		try{
			var tags = getOmnitureData()['prop34'];
			return tags && (typeof tags === 'string') && (tags.split('|').join(','));
		}catch(e){}
		 
	  },
	  'adblock': function() {
		try{
			return !!window.abp;  
		}catch(e){}
	  },
	  'transactionId': function(conf) {
		try{
			if(conf.el.getAttribute('data-omniture-tracking')){
			  var omnitureTrackingVars = conf.el.getAttribute('data-omniture-tracking');
			  var parsedVars = JSON.parse(omnitureTrackingVars);
			  return parsedVars["evars"]["transactionID"];
			} else {
			  return null
			}
		}catch(e){}
	  }
	  
  }
};

window.cs_cmd = window.cs_cmd || [];

window.cs_cmd.push(function() {
	if(typeof window.Purch.cs_data !== "undefined"){
		delete window.Purch.cs_data['PAGE'];
		delete window.Purch.cs_data['PAGE_DOMAIN'];
        delete window.Purch.cs_data['COOKIES'];
		DiscoveryConf.d['timestamp'] =  '%CB%';
		DiscoveryConf.d['client_ts'] = '%CB%';
	}else{
		DiscoveryConf.d['SITE'] =  '%SITE%';
		DiscoveryConf.d['clickURL'] =  '%URL%';
		DiscoveryConf.d['GAID'] =  '%GAID%';
		DiscoveryConf.d['client_ts'] =  '%CB%';        
	}
	try{
		DiscoveryConf.init = false;
		var dscv = new window.Purch.Discovery(DiscoveryConf);
		dscv.init();
 
	}catch(e){}
});

})();

/*Do not change the way clickstream is loaded please!!!*/
(function(url) { var s=document.createElement('script');s.type='text/javascript';document.getElementsByTagName('head')[0].appendChild(s);s.src = url;
})('//assets.purch.com/loe/latest/REVISION.js?t='+(new Date()).getTime());



</script>
<script type="text/javascript">
function consentCallback(config) {
  var newsletter_consent_container = document.querySelectorAll('.newsletter_consent_container');
  if (typeof config.message !== 'undefined') for (var i = 0; i < newsletter_consent_container.length; i++) newsletter_consent_container[i].innerHTML = config.message;
}
</script>
<script>
(function(){
    var isDebug = false;
    var debug = isDebug ? console.log : function(){};

    var gaLayer;
    if(!window.gtmDataLayer && ! window.dataLayer){
        gaLayer = window.gtmDataLayer  = window.dataLayer = []
    } else {
        gaLayer = window.gtmDataLayer ||  window.dataLayer;
    }
    debug('ICU:gaLayer -- data:', gaLayer);

    function encase(fn, x) {
        try {
            return fn(x);
        } catch(err) {
            return null;
        }
    }

    function getCookie(name) {
        var list = (document.cookie)
            .split('; ')
            .filter(function(s) { return s.includes(name + '='); })
            .map(function(s) { return s.slice((name + '=').length); });
        return encase(JSON.parse, encase(window.atob, list[0] || null));
    }

    function uuidv4() {
        return 'xxxxxxxx-xxxx-4xxx-yxxx-xxxxxxxxxxxx'.replace(/[xy]/g, function(c) {
            var r = Math.random() * 16 | 0, v = c == 'x' ? r : (r & 0x3 | 0x8);
            return v.toString(16);
        });
    }

    // Get ICU cookie
    var icuCookie = getCookie('icu');
    debug('ICU:icuCookie -- data:', icuCookie);

    // Check if cookie has fingerprint
    var fingerprint = icuCookie && icuCookie['fingerprint'] || null;
    debug('ICU:fingerprint -- data:', fingerprint);

    // Check if cookie has gusID
    var gusID = icuCookie && icuCookie['gus_id'] || null;
    debug('ICU:gusID -- data:', gusID);

    // Check if cookie has global_fingerprint
    var global_fingerprint = icuCookie && icuCookie['global_fingerprint'] || 'ffp-' + uuidv4();
    debug('ICU:global_fingerprint -- data:', global_fingerprint);

    // Create new data
    var data = Object.assign({},
        { fingerprint: fingerprint || global_fingerprint },
        { global_fingerprint: global_fingerprint },
        gusID ? { gus_id: gusID } : null
    );
    debug('ICU:data -- data:', data);

    // Push ga data to gaLayer
    gaLayer.push({
        'event': 'purch_icu',
        'datas': data
    });
    debug('ICU:gaLayer -- data:', gaLayer);

    // Set cookie with updated data
    var newCookie = Object.assign({}, icuCookie, data);
    document.cookie = 'icu=' + window.btoa(JSON.stringify(newCookie));
    debug('ICU:newCookie -- data:', newCookie);

    // Load icu.js file
    var s=document.createElement('script');
    s.type='text/javascript';
    s.defer = true;
    s.src ='//assets.purch.com/loe/icu/1.0.1-35/icu.js';
    s.addEventListener('load', async function() {
        // When icu.js is loaded, call ICU function with config
        Purch.cs_extradata = Purch.cs_extradata || {};

        function sleep(ms) { return new Promise((resolve) => setTimeout(resolve, ms)) }

        async function isGaLoaded() {
            let i = 0;
            while (typeof ga === "undefined" && i < 3) {
                i = i + 1;
                await sleep(1000);
            }
            return ga;
        }

        async function isTmnLoaded() {
            let i = 0;
            while (typeof tmntag.pubtargets === "undefined" && i < 3) {
                i = i + 1;
                await sleep(1000);
            }
            return tmntag;

        }

        // need to wait until ga and tmntags have been loaded
        var gaObject = await isGaLoaded();
        var tmnTag = await isTmnLoaded();

        window.ICU({
            debug: isDebug,
            tmnTag: tmnTag,
            gaObject: gaObject,
            dataLayers: [ Purch.cs_extradata || []],
            gaDataLayer: window.gtmDataLayer ||  window.dataLayer || [],
        });
    });
    document.getElementsByTagName('head')[0].appendChild(s);
})();

</script>


        </head>

    <body class="body-main migration article-page ">
    <script>
        require([
            'jquery',
            'Purch/Utils/Lazy',
            'Purch/Utils/DelayedHover',
            'Purch/Link/DecodeLive'
        ], function($, Lazy, DelayedHover) {
            new Lazy({init: true, offsetY:150, delegateOn: 'body'});
            new DelayedHover();
        });
    </script>

        <!-- Google Tag Manager (noscript) -->
    <noscript><iframe src="//www.googletagmanager.com/ns.html?id=ReplaceGTMIdInsiteSiteBundle" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
    <!-- End Google Tag Manager (noscript) -->

                
    
                    <section class="body-section">
                <section class="header-container">
                            <section class="page-top-container nolinks">        <div class="header-wrapper base-header ">
                    <input class="header-toggle" id="menuToggle" type="checkbox" onchange="document.body.style.overflow = this.checked ? 'hidden': ''; "/>
            <input class="header-toggle" id="searchToggle" type="checkbox"/>
            <input class="header-toggle" id="memberModuleToggle" type="checkbox"/>
            <header class="header header-main z-layer-8">
                <div class="header-g">
                                            <label for="menuToggle" class="header-toggle-menu mobon tableton"></label>
                        <div class="header-brand"><a title="Newsarama" href="https://www.newsarama.com/" class="header-logo font-tab-131"><svg class="logo" xml:space="preserve" viewBox="0 0 505 68" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><defs><polygon id="path-1" points="55.851 50.5228 55.851 0.8118 0.6383 0.8118 0.6383 50.5228 55.851 50.5228"></polygon><polygon id="path-3" points="66.951 0.936 0.887 0.936 0.887 66.9998 66.951 66.9998 66.951 0.936"></polygon></defs><g id="Page-1" stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g id="White-logo"><g id="Page-1"><polygon id="Fill-1" fill="#FEFEFE" points="33.0696 9.2285 33.0696 35.3175 12.7616 9.2285 -0.0004 9.2285 -0.0004 58.5865 13.5386 58.5865 13.5386 31.5095 34.6216 58.5865 46.6076 58.5865 46.6076 9.2285"></polygon><polygon id="Fill-2" fill="#FEFEFE" points="54.1614 9.2282 93.8594 9.2282 93.8594 20.8622 67.6994 20.8622 67.6994 28.3362 91.3914 28.3362 91.3914 39.1252 67.6994 39.1252 67.6994 46.9522 94.2124 46.9522 94.2124 58.5862 54.1614 58.5862"></polygon><polygon id="Fill-3" fill="#FEFEFE" points="99.0819 9.2282 113.5369 9.2282 122.1399 37.7852 131.6589 9.0872 143.4349 9.0872 152.9529 37.7852 161.5559 9.2282 175.7289 9.2282 159.2299 58.9392 147.3129 58.9392 137.3699 30.5232 127.4979 58.9392 115.5819 58.9392"></polygon><g id="Group-20" transform="translate(173.000000, 0.064300)"><path d="M0.6861,51.1887 L8.3021,42.0927 C13.1671,45.9707 18.5971,48.0157 24.3071,48.0157 C27.9751,48.0157 29.9491,46.7467 29.9491,44.6317 L29.9491,44.4907 C29.9491,42.4457 28.3271,41.3167 21.6281,39.7667 C11.1211,37.3687 3.0131,34.4067 3.0131,24.2527 L3.0131,24.1117 C3.0131,14.9457 10.2761,8.3177 22.1211,8.3177 C30.5121,8.3177 37.0711,10.5737 42.4291,14.8747 L35.5891,24.5357 C31.0761,21.3617 26.1411,19.6697 21.7691,19.6697 C18.4551,19.6697 16.8331,21.0807 16.8331,22.8437 L16.8331,22.9847 C16.8331,25.2407 18.5251,26.2277 25.3661,27.7787 C36.7181,30.2477 43.7691,33.9137 43.7691,43.1507 L43.7691,43.2917 C43.7691,53.3747 35.8011,59.3687 23.8141,59.3687 C15.0711,59.3687 6.7501,56.6187 0.6861,51.1887" id="Fill-4" fill="#FEFEFE"></path><path d="M137.7856,32.856 C142.4386,32.856 145.1196,30.6 145.1196,27.003 L145.1196,26.863 C145.1196,22.984 142.2986,21.01 137.7156,21.01 L128.7596,21.01 L128.7596,32.856 L137.7856,32.856 Z M115.0816,9.164 L138.4206,9.164 C145.9646,9.164 151.1836,11.138 154.4976,14.523 C157.3886,17.343 158.8686,21.151 158.8686,26.016 L158.8686,26.157 C158.8686,33.702 154.8496,38.708 148.7156,41.317 L160.4896,58.522 L144.6956,58.522 L134.7546,43.574 L134.6126,43.574 L128.7596,43.574 L128.7596,58.522 L115.0816,58.522 L115.0816,9.164 Z" id="Fill-6" fill="#FEFEFE"></path><path d="M194.7905,39.0608 L189.2905,25.0288 L183.7195,39.0608 L194.7905,39.0608 Z M182.8035,8.8118 L195.9885,8.8118 L217.0015,58.5228 L202.3345,58.5228 L198.7385,49.7078 L179.7005,49.7078 L176.1745,58.5228 L161.7895,58.5228 L182.8035,8.8118 Z" id="Fill-8" fill="#FEFEFE"></path><polygon id="Fill-10" fill="#FEFEFE" points="220.5903 9.1639 235.0443 9.1639 246.8203 28.2719 258.5953 9.1639 273.0503 9.1639 273.0503 58.5219 259.4423 58.5219 259.4423 30.1759 246.8203 49.4969 246.5383 49.4969 233.9873 30.3179 233.9873 58.5219 220.5903 58.5219"></polygon><g id="Group-14" transform="translate(276.000000, 8.000000)"><mask id="mask-2" fill="white"><use xlink:href="#path-1"></use></mask><g id="Clip-13"></g><path d="M33.6393,31.0608 L28.1393,17.0288 L22.5683,31.0608 L33.6393,31.0608 Z M21.6513,0.8118 L34.8373,0.8118 L55.8513,50.5228 L41.1833,50.5228 L37.5873,41.7078 L18.5493,41.7078 L15.0233,50.5228 L0.6383,50.5228 L21.6513,0.8118 Z" id="Fill-12" fill="#FEFEFE" mask="url(#mask-2)"></path></g><g id="Group-17" transform="translate(45.000000, 0.000000)"><mask id="mask-4" fill="white"><use xlink:href="#path-3"></use></mask><g id="Clip-16"></g><path d="M66.951,33.9678 C66.951,15.7248 52.162,0.9358 33.919,0.9358 C15.676,0.9358 0.887,15.7248 0.887,33.9678 C0.887,52.2108 15.676,66.9998 33.919,66.9998 C52.162,66.9998 66.951,52.2108 66.951,33.9678" id="Fill-15" fill="#AB1F23" mask="url(#mask-4)"></path></g><path d="M83.2836,43.1685 L71.6706,43.1685 C70.8896,43.1685 70.3236,42.4245 70.5306,41.6715 L71.4726,38.2575 L84.6386,38.2575 L83.2836,43.1685 Z M67.9696,14.7905 L65.2176,24.7675 L84.7146,24.7675 C86.5476,24.7675 87.8776,26.5135 87.3906,28.2805 L86.8676,30.1145 L63.7256,30.1145 L60.5456,41.7045 C58.9576,47.4595 63.2876,53.1455 69.2576,53.1455 L90.4706,53.1455 L97.2166,28.7775 C99.1636,21.7445 93.8726,14.7905 86.5756,14.7905 L67.9696,14.7905 Z" id="Fill-18" fill="#FFFFFF"></path></g></g></g></g></svg></a></div><div class="header-content "><div class="header-nav"><div class="header-nav-inner"><div class="header-search-bar"><meta itemprop="url" content="https://www.newsarama.com/"/><form action="/search" class="header-search-form"><div class="p-g space--l10 header-search-inner"><div class="p-u-3-4 p-u-lg-1"><div class="space-l10"><input type="text" placeholder="What are you looking for ?" type="text" name="q" required></div></div><div class="p-u-1-4 mobon tableton"><div class="space-l10"><button class="p-button p-u-1-4 fa" type="submit"><span>GO</span></button></div></div></div></form></div><div class="p-menu p-menu-horizontal"><ul class="header-nav-links"><li class="p-menu-item"><a class="header-nav-link"  title="Home" href="/">
                Home
            </a></li><li class="p-menu-item"><a class="header-nav-link"  title="Comics" href="/comics">
                Comics
            </a></li><li class="p-menu-item"><a class="header-nav-link"  title="Film&amp;TV" href="/film-tv">
                Film&amp;TV
            </a></li><li class="p-menu-item"><a class="header-nav-link"  title="Games" href="/games">
                Games
            </a></li><li class="p-menu-item"><a class="header-nav-link"  title="Countdowns" href="/countdowns">
                Countdowns
            </a></li><li class="p-menu-item"><a class="header-nav-link"  title="Previews" href="/image-albums">
                Previews
            </a></li><li class="p-menu-item"><a class="header-nav-link"  title="Topics" href="/topics">
                Topics
            </a></li><li class="p-menu-item p-menu-has-children p-menu-allow-hover header-social moboff e681f87f0b456389cf1a2c4a4b2a8a5b "><ul class="p-u p-menu p-menu-horizontal header-social-btn"><li class="p-u"><span class="fa fa-facebook"></span></li><li class="p-u"><span class="fa fa-rss"></span></li><li class="p-u"><span class="fa fa-twitter"></span></li></ul><ul itemscope itemtype="https://schema.org/Organization" class="p-menu-children header-social-links"><link itemprop="url" content="https://www.newsarama.com/"/><li class="p-menu-item"><a itemprop="sameAs" title="Follow Us" href="https://www.facebook.com/pages/Newsarama/18648183297" target="_blank" class="fa fa-facebook">Follow Us</a></li><li class="p-menu-item"><a itemprop="sameAs" title="Subscribe" href="https://www.newsarama.com/home/feed/site.xml" target="_blank" class="fa fa-rss">Subscribe</a></li><li class="p-menu-item"><a itemprop="sameAs" title="Follow Us" href="https://twitter.com/Newsarama" target="_blank" class="fa fa-twitter">Follow Us</a></li></ul></li><li class="p-menu-item header-search moboff e681f87f0b456389cf1a2c4a4b2a8a5b "><label class="fa fa-search" for="searchToggle"></label></li></ul></div></div></div>                        </div>
                                    </div>
            </header>
            </div>
</section>
            </section>
    <div id="ctBoc">
        <div class="overall">
            <section class="page">
                <section class="page-top-promo nolinks">
                                                        
    <div id="out-of-page">
        <script type="text/javascript">
                            if (window.tmntag && window.tmntag.cmd) {
                    tmntag.cmd.push(function() {
                        if (window.tmntag && tmntag.adTag) {
                            tmntag.adTag('out-of-page', false);
                        }
                    });
                }
            
                    </script>
    </div>
                        
    <div id="header_leaderboard">
        <script type="text/javascript">
                            if (window.tmntag && window.tmntag.cmd) {
                    tmntag.cmd.push(function() {
                        if (window.tmntag && tmntag.adTag) {
                            tmntag.adTag('header_leaderboard', false);
                        }
                    });
                }
            
                    </script>
    </div>
                    
                    </section>

                                
                                                                                <section class="page-content flex ">				<section class="page-content-leftcol flex-1">    <ul class="breadcrumb" itemscope="" itemtype="https://schema.org/BreadcrumbList"><li class="fa breadcrumb-item" itemprop="itemListElement" itemscope="" itemtype="https://schema.org/ListItem"><a title="Newsarama" href="/" itemprop="item"><span itemprop="name">Newsarama</span></a><meta itemprop="position" content="1"></li><li class="fa fa-angle-right breadcrumb-item" itemprop="itemListElement" itemscope="" itemtype="https://schema.org/ListItem"><a title="Films & TV" href="/film-tv" itemprop="item"><span itemprop="name">Films & TV</span></a><meta itemprop="position" content="2"></li></ul>
<header class="article-headline">
    
                
        <h1 class="h1 article-title">HE-MAN Documentary POWER OF GRAYSKULL Coming to Home Video</h1>
        <div class="article-metas space-b20">
            <span class="article-author" itemprop="author">By <a href="https://www.newsarama.com/authors/?name=Newsarama%20Staff">Newsarama Staff</a></span>
            <time datetime="2019-08-02T14:16:00+00:00" itemprop="datePublished"> August 2, 2019 07:16am ET</time>

                    </div>
                <div class="article-share-bar">
    <ul>
        <li class="st_facebook_custom fa fa-facebook"></li>
                <li class="st_twitter_custom fa fa-twitter" st_via="Newsarama"></li>
                <li class="st_googleplus_custom fa fa-google-plus"></li>
        <li class="st_email_custom fa fa-envelope"></li>
        <li class="st_sharethis_custom fa fa-share-alt"></li>
    </ul>
</div>    </header>
    <div class="content clear-both">
                                
    <div id="m-in-article1">
        <script type="text/javascript">
                            if (window.tmntag && window.tmntag.cmd) {
                    tmntag.cmd.push(function() {
                        if (window.tmntag && tmntag.adTag) {
                            tmntag.adTag('m-in-article1', false);
                        }
                    });
                }
            
                    </script>
    </div>
        
    <div id="m-in-article2">
        <script type="text/javascript">
                            if (window.tmntag && window.tmntag.cmd) {
                    tmntag.cmd.push(function() {
                        if (window.tmntag && tmntag.adTag) {
                            tmntag.adTag('m-in-article2', false);
                        }
                    });
                }
            
                    </script>
    </div>
        
    <div id="m-in-article3">
        <script type="text/javascript">
                            if (window.tmntag && window.tmntag.cmd) {
                    tmntag.cmd.push(function() {
                        if (window.tmntag && tmntag.adTag) {
                            tmntag.adTag('m-in-article3', false);
                        }
                    });
                }
            
                    </script>
    </div>
        
    <div id="in-article-1">
        <script type="text/javascript">
                            if (window.tmntag && window.tmntag.cmd) {
                    tmntag.cmd.push(function() {
                        if (window.tmntag && tmntag.adTag) {
                            tmntag.adTag('in-article-1', false);
                        }
                    });
                }
            
                    </script>
    </div>
    
        <div class="article-thumbnail">
                        <img data-src="https://img.purch.com/o/aHR0cDovL3d3dy5uZXdzYXJhbWEuY29tL2ltYWdlcy9pLzAwMC8yNjIvMTMyL2kwMi9QT1dFUk9GR1JFWVNLVUxMLUtFWUFSVC5qcGc=" alt="The Power of Grayskull" class="lazy p-img">
                    <figcaption class="fig-cap" id="nointelliTXT">
                <cite class="fig-credit">Credit: High Octane Pictures </cite>
    </figcaption>
    </div>
    
    
<figure class="figure thumb-right">
    	<div class="magnify-wrapper iZoom">
						<img class="pure-img" big-src="https://img.purch.com/h/1400/aHR0cDovL3d3dy5uZXdzYXJhbWEuY29tL2ltYWdlcy9pLzAwMC8yNjIvMTMyL29yaWdpbmFsL1BPV0VST0ZHUkVZU0tVTEwtS0VZQVJULmpwZz8xNTY0NzU2MTE2" src="https://img.purch.com/w/192/aHR0cDovL3d3dy5uZXdzYXJhbWEuY29tL2ltYWdlcy9pLzAwMC8yNjIvMTMyL2kzMDAvUE9XRVJPRkdSRVlTS1VMTC1LRVlBUlQuanBnPzE1NjQ3NTYxMTY=" alt="" >
				
	</div>
		<figcaption class="fig-cap" id="nointelliTXT">
            						    <cite class="fig-credit">Credit: High Octane Pictures </cite>
				</figcaption>
	    </figure>

<p>
	<em>Press Release</em></p>
<p>
	Discover the history of Mattel&#39;s definitive action figure toy line this September!<br />
	&nbsp;<br />
	From Randall Lobb and Robert McCallum,&nbsp;<strong>THE POWER OF GRAYSKULL: The Definitive History of He-Man and the Masters of the Universe</strong>&nbsp;chronicles the beginnings and blockbuster-success of &lsquo;80s toy sensation He-Man in an exhaustive, captivating 95 minute documentary that melts back the plastic on Eternia&rsquo;s best-kept secrets!<br />
	&nbsp;<br />
	Featuring Dolph Lundgren, Frank Langella, Richard Edlund, J. Michael Straczynski, Alan Oppenheimer and many more, the &ldquo;fantastic documentary&rdquo;*&nbsp;<strong>THE POWER OF GRAYSKULL</strong>&nbsp;will be available on digital and DVD for the first time this September from High Octane Pictures.<br />
	&nbsp;<br />
	In the early 1980s He-Man arrived on the scene and hit the world with a punch as powerful as the character himself. Designed in the wake of Conan the barbarian and under the shadow of Star Wars, He-Man&#39;s surprising popularity spawned a multi billion dollar empire that included toys, comic books, cartoons, live-action movies and a literal sister spinoff show - She-Ra - and continues to appeal to a ravenous fan-base today. Watch as artists, creators and collaborators dig deep, tell tales and share the surprising developments of an unlikely, unparalleled pop culture success in this Definitive History of He-Man and the Masters of the<br />
	Universe. Do you have the power?<br />
	&nbsp;<br />
	<strong>THE POWER OF GRAYSKULL</strong>&nbsp;has the power September 3 on DVD and Digital from High Octane Pictures.</p>

                
    <div id="m-in-article-3">
        <script type="text/javascript">
                            if (window.tmntag && window.tmntag.cmd) {
                    tmntag.cmd.push(function() {
                        if (window.tmntag && tmntag.adTag) {
                            tmntag.adTag('m-in-article-3', false);
                        }
                    });
                }
            
                    </script>
    </div>
            </div>
    
    <div id="below_article">
        <script type="text/javascript">
                            if (window.tmntag && window.tmntag.cmd) {
                    tmntag.cmd.push(function() {
                        if (window.tmntag && tmntag.adTag) {
                            tmntag.adTag('below_article', false);
                        }
                    });
                }
            
                    </script>
    </div>
    
        <div class="space-t40">
                    <div class="comments">
            <script type="text/javascript">
                var gtmDataLayer = gtmDataLayer || [];
                gtmDataLayer.push({
                    'event': 'spot_im_id',
                    'spot_im_id': 'sp_pI2ijZdp'
                });
            </script>
            <div class="space-t20 spot-im-frame-inpage" data-post-id="46352-he-man-documentary-power-of-grayskull-coming-to-home-video"></div>
        </div>
    
    </div>
</section>
	
	
			<section class="page-content-rightcol">
			            
    <div id="rightcol_top">
        <script type="text/javascript">
                            if (window.tmntag && window.tmntag.cmd) {
                    tmntag.cmd.push(function() {
                        if (window.tmntag && tmntag.adTag) {
                            tmntag.adTag('rightcol_top', false);
                        }
                    });
                }
            
                    </script>
    </div>
    <div class="right-rail-section">
        <span class="h2 titles">Twitter activity</span>        <a class="twitter-timeline" href="https://twitter.com/Newsarama" data-widget-id="329753786967007232">Tweets by @Newsarama</a>
    </div>
    
    <div id="rightcol_mid">
        <script type="text/javascript">
                            if (window.tmntag && window.tmntag.cmd) {
                    tmntag.cmd.push(function() {
                        if (window.tmntag && tmntag.adTag) {
                            tmntag.adTag('rightcol_mid', false);
                        }
                    });
                }
            
                    </script>
    </div>
    
    <div id="rightcol_bottom">
        <script type="text/javascript">
                            if (window.tmntag && window.tmntag.cmd) {
                    tmntag.cmd.push(function() {
                        if (window.tmntag && tmntag.adTag) {
                            tmntag.adTag('rightcol_bottom', false);
                        }
                    });
                }
            
                    </script>
    </div>

		</section>
	</section>
                                    
                                                                                    </section>
        </div>
    </div>

    <section class="page-footer nolinks">
        <footer class="footer content-wrapper">
    <div class="center-content pure-g">
			<div class="pure-u-1 mq-lg-off m-net-links space-B30">
				<a href="/">Home</a><a href="/about">About Us</a>
			</div>  
			<div class="net-links pure-u-1 pure-u-med-1-4 pure-u-lg-1-4">
				<header class="footer-title">Company</header>
				<ul>
						<li class="net-link"><a href="http://purch.com/" target="_blank">Company Info</a></li>
						<li class="net-link"><a href="/about">About Us</a></li>
						<li class="net-link"><a href="http://purch.com/#contact" target="_blank">Contact Us</a></li>
						<li class="net-link"><a href="http://purch.com/advertise/" target="_blank">Advertise with Us</a></li>
						<li class="net-link"><a href="http://purch.com/#contact" target="_blank">Using Our Content</a></li>
						<li class="net-link"><a href="https://enveritasgroup.com/contact-us/" target="_blank">Licensing &amp; Reprints</a></li>
						<li class="net-link"><a href="http://purch.com/terms-of-use-and-sale/" target="_blank">Terms of Use and Sale</a></li>
						<li class="net-link"><a href="http://purch.com/copyright-policy/" target="_blank">Copyright Policy</a></li>
						<li class="net-link"><a href="http://purch.com/privacy-policy/" target="_blank">Privacy Policy</a></li>
				</ul>
			</div>
			<div class="net-links pure-u-1 pure-u-med-1-4 pure-u-lg-1-4">
				<header class="footer-title">Network</header>
				<ul>
						<li class="net-link"><a href="http://www.toptenreviews.com/">Top Ten Reviews</a></li>
						<li class="net-link"><a href="http://www.tomsguide.com/">Tom's Guide</a></li>
						<li class="net-link"><a href="http://www.laptopmag.com/">Laptop Mag</a></li>
						<li class="net-link"><a href="http://www.tomshardware.com/">Tom's Hardware</a></li>
						<li class="net-link"><a href="http://www.space.com/">Space.com</a></li>
						<li class="net-link"><a href="http://www.livescience.com/">Live Science</a></li>
						<li class="net-link"><a href="http://www.anandtech.com/">AnandTech</a></li>
				</ul>
			</div>
			<div class="pure-u-1 pure-u-med-1-2 pure-u-lg-1-2">
				<div class="unit-r">
					<div class="follow mod top-mod">
							<header class="footer-title">FOLLOW US</header>
							<div class="footer-social">
                                                                    <a href="https://www.facebook.com/pages/Newsarama/18648183297" target="_blank" class="fa fa-facebook"></a>
                                                                    <a href="https://twitter.com/Newsarama" target="_blank" class="fa fa-twitter"></a>
                                                                    <a href="https://plus.google.com/+newsarama/posts" target="_blank" class="fa fa-google-plus"></a>
                                                                    <a href="https://www.newsarama.com/home/feed/site.xml" target="_blank" class="fa fa-rss"></a>
                                                                    <a href="https://www.youtube.com/user/VideoFromNewsarama" target="_blank" class="fa fa-youtube"></a>
                                							</div>
					</div>
					<div class="mod line">
							<header class="footer-title"> SUBSCRIBE TO NEWSARAMA</header>
															<form class="inline-form" action="/newsletter" method="post" id="footer-newsletter">
									<input class="subscribe unit form-inset" type="email" name="email" placeholder="enter email here ..." required>
									<input type="hidden" name="nlPlacement" value="footer">
									<button class="btn">SUBMIT</button>
								</form>
												</div>
					<div class="mod branding">
							<a href="http://purch.com/">

																		<img src="https://img.purch.com/o/aHR0cHM6Ly93d3cubmV3c2FyYW1hLmNvbS9pbWcvcHVyY2gtbG9nby5wbmc=" width="135" height="41" alt="Purch">
																</a>
							<p class="copy-right">Copyright &copy;
									<script type="text/javascript">document.write(new Date().getFullYear());</script>
									All Rights Reserved.
							</p>
					</div>
			</div>
		</div>
</footer>    </section>
        </section>
                        
    <div id="mobile-anchor">
        <script type="text/javascript">
                            if (window.tmntag && window.tmntag.cmd) {
                    tmntag.cmd.push(function() {
                        if (window.tmntag && tmntag.adTag) {
                            tmntag.adTag('mobile-anchor', false);
                        }
                    });
                }
            
                    </script>
    </div>
    
    <div id="interstitial">
        <script type="text/javascript">
                            if (window.tmntag && window.tmntag.cmd) {
                    tmntag.cmd.push(function() {
                        if (window.tmntag && tmntag.adTag) {
                            tmntag.adTag('interstitial', false);
                        }
                    });
                }
            
                    </script>
    </div>

    
    
                
                                
                
                
                                
                                
                        <script type="text/javascript">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</script>
    
                
    <script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"6ef1e23532","applicationID":"21953337","transactionName":"YFRQMkdRDBZSBxJRDFkecwVBWQ0LHAoDTxBoUl0IQVUMEWwFFEwKVF1X","queueTime":0,"applicationTime":51,"atts":"TBNTRA9LHxg=","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
